X.org xserver 1.4以降(Fedora 9, Ubuntu8.04等)において、現状のvnc.soは動作しないことが分かっています。

X11R6.9.0ベースではもはや追随が厳しくなってきたため、X11R7.x対応のVNCへの乗り換えを検討中です。

そこでまずModular xf4vncへの移行を考えたのですが、なかなかリリースされないのと、Xvncの-depth 16での動作がおかしい問題があり、とりあえずパッチだけ置いておきます。

2008/7/24現在のModular xf4vnc、(または、xorg-server-1.5に xorg-server-1.5-xf4vnc.patch を当てたもの)に適用可能です。

Fedora 9で使えることを確認済です。

なお、Ubuntu 8.04等、xorg-server-1.4の場合は、上記xf4vncが使えないので、xorg-server-1.4に

を当てたものに適用してください。

X.org xserver 1.4と1.5で対応が変わってしまうところが厄介...。

2009/2現在、最有力と考えているのはTightVNCです。Fedora11のTightVNCをベースにしようとしています。


添付ファイル: filexorg-server-1.4-xf4vnc.patch 640件 [詳細] filexf4vnc-metavnc.patch 521件 [詳細]

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2009-02-07 (土) 16:54:11 (3001d)