The RPMS of MetaVNC 0.6.5 handles the followings automatically so no modifications are required. To use MetaVNC on Fedora Core 5 or 6, some modifications are required.

Directory hierarchy

vnc.so

X11R7 does not use /usr/X11R6 hierarchy any longer, so you may encounter problem on loading vnc.so. The following may be the easiest way to solve it.

cd /usr/lib/xorg/modules/extensions
ln -s /usr/X11R6/lib/modules/vnc.so .

RgbPath? (Xvnc)

Xvnc assumes /usr/X11R6 hierarchy which is obsoleted on X11R7, so, for example, emacs does not launch because of the change of RgbPath?. To specify the RfbPath?, launch the vncserver with the following option.

vncserver -co /usr/share/X11/rgb

SELinux

If SELinux is enabled, security context may have to be changed as follows.

chcon system_u:object_r:textrel_shlib_t /usr/X11R6/lib/modules/vnc.so

Front page   Edit Freeze Diff Backup Upload Copy Rename Reload   New List of pages Search Recent changes   Help   RSS of recent changes
Last-modified: 2007-09-15 (Sat) 14:10:46 (3658d)